Frequently Asked Questions

Do I need special software?

No, all you need is a web browser — any browser will do.

But since this site makes use of features only available in modern browsers, you should make sure your's is up to date. I recommend (in this order):

  1. Chrome
  2. Firefox
  3. Safari
  4. Internet Explorer version 8 or later.
© 2012 The University of Adelaide
Last Modified 21/03/2012
CRICOS Provider Number 00123M
find us on facebook

Service Charter | Copyright | Privacy | Disclaimer